
Communication Protocol Test Harness Quick Start Guide  

Overview 
The Communication Protocol Test Harness is a Windows application that acts like a typical Master or 
Slave device. It can be configured through a Graphical User Interface (GUI) and/or Tcl/Tk scripts to 
provide automated testing or simulation of a device. Example scripts are included to demonstrate how to 
open a connection to a device and perform tasks such as polling, performing control operations, and 
setting input or output values via Tcl/Tk. The primary focus of the Quick Start Guide is configuring and 
using the Test Harness through the GUI. 
 
This Quick Start Guide describes how to use the GUI to configure the Test Harness, issue commands 
(for a Master), generate simulated data (for a Slave), and display data. The examples in this guide use 
the DNP Protocol. Other protocols are very similar. 
 
The Communication Protocol Test Harness makes extensive use of “tool tips.” To learn the meaning of 
any button or data entry field, position the cursor over it and wait a few seconds. A tool tip will appear 
with a description of the button or field. 

Using an Existing Workspace 
The Test Harness ships with several example workspaces. Many of these example workspaces create 
both Master and Slave sessions, so communications can occur immediately without requiring a 
connection to an external device. These workspaces provide a good demonstration of the capability of 
the Test Harness and are an excellent tool for learning about the protocols. 
 
When the Test Harness is started, the Test Harness main window and a dialog box to select the Test 
Harness Workspace are displayed. The Select Test Harness Workspace dialog box is shown in Figure 1, 
and the main window is shown in Figure 2. 
 

 
Figure 1. Test Harness Select Workspace dialog 
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Figure 2. Test Harness Main Window 

 
Select one of the predefined workspaces, or select “Cancel” and continue to the next section to create a 
customized workspace. 

Opening a Connection to a Device 
Click on the Open Connection button ( ). An Open Connection Dialog box will appear, as shown in 
Figure 3. Select the protocol and indicate whether the Test Harness should act as a Master [Controlling 
Station] or Slave [Controlled Station] for this connection. 
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Figure 3. Open Connection Dialog 

Press the Open button and the appropriate Open dialog box is displayed.  
 
The Open dialog box contains tabs for Channel, Session, and Next Step. For IEC 60870-5 protocols, a 
Sector tab is also displayed. Click on each tab to configure the connection before pressing the Open 
button. 

Session Tab 
The Session tab allows configuration of the session parameters. The Session tab for a DNP Master 
session is shown in Figure 4. 
 

 
Figure 4. Session Tab for DNP3 Master Session 

 
The Session Name field specifies a name for the session. This name will be used in the Data view 
window.  
 



The remaining fields vary for each protocol. For information on each field, view the Tool Tips by 
holding the cursor over the field for a few seconds. 
 

Channel Tab 
The Channel tab supports opening a new channel (as shown in Figure 5) or establishing a multidrop 
connection on a previously opened channel. Use the scroll arrows to select a previously opened channel 
to add this new connection to an existing channel. 
 

 
Figure 5. Example Open Dialog Box 

 
The Channel Name field specifies the name that will be displayed in the Protocol Analyzer display, the 
Data Window, and the channel scroll box. 
 
The Connection Type area specifies the desired type of connection (e.g., serial or TCP/IP). The 
Parameters box is automatically updated to show parameters specific for the selected connection type. 
 
The Advanced Settings button allows configuration of additional parameters for the channel. Pressing 
this button will open the Advanced Settings dialog box. The default values for these settings will 
normally establish communications, so it is not usually necessary to open the Advanced Settings dialog 
box. 
 
The Equivalent Tcl command line arguments box displays the Tcl command that will be issued to the 
Test Harness as a result of the specified configuration options. This box is read-only; the contents cannot 
be modified. The Copy to Clipboard button copies this command to the clipboard. This option is very 
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useful for creating commands in the GUI and pasting them into a script that will be used for automation 
of the Test Harness. 
 

Sector Tab 
The Sector tab appears only for IEC 60870-5 protocols. This tab configures IEC 60870-5 Sectors 
(ASDU Addresses). For information on each field in the Sector tab, view the Tool Tips by holding the 
cursor over the field for a few seconds. 
 

Next Step Tab 
The Next Step tab defines further actions, such as opening a Command window and/or a Data view 
window.  
 
After reviewing each tab, press the Open button to open a connection to the device. Depending on the 
options selected, the following windows may be opened. 
 

Data Window 
The Data Window will be opened when a connection is opened if it is selected in the Next Step tab. The 
Data Window can also be opened by pressing the  button on the tool bar of the Test Harness main 
window. 
 
The Data Window displays data points and values. An example of the Data Window is shown in Figure 
6. The order of the columns can be changed by dragging the column header. Customized descriptions for 
each point are entered by clicking in the Description field.  
 
Channels, sessions, sectors, and slave session data points are all modified by clicking the right mouse 
button and selecting the desired operation.  To change the value of one or more Slave Data points in the 
Data Window, select the desired row(s) and right click to access the options available for the selected 
data type. 
 

 
Figure 6. Example Data Window 



Command Window 
The Command window will be opened when a connection is opened if it is selected in the Next Step tab. 
The Commands Window can also be opened by pressing the  button on the tool bar of the Test 
Harness main window. 
 
The Command window provides a convenient means of issuing commands. The Command Window is 
available for DNP3, Modbus, IEC 60870-5-101, and IEC 60870-5-104 Master connections. A command 
window for the IEC 60870-5-103 protocol will be available soon. The DNP3 Command Window is 
shown in Figure 7. 
 

 
Figure 7. Example DNP3 Commands Window 

 
Clicking on the button to the left of the command description executes the command. Customize the 
command by double clicking on the command description. The Configure window also allows 
configuration of a repeat interval. If a repeat interval is configured, a “progress bar” underneath the 
command description gives a graphic indication of when the command will next be executed. 
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A new command window may be opened for each remote device or one command window may be used 
to access multiple devices by using the session menu to switch between target devices. 
 
Tool Tips describe the purpose of each command, as well as the meaning of all configuration options in 
the Configure dialog box. 

Simulator Window 
When the Test Harness is acting as a Slave, a simulator may be attached to the session or sector to 
automatically change data values on a timed interval or through a functional front panel image of a real 
or virtual device. An example of a Slave simulator is shown in Figure 8. 
 
New simulators can be added to the Test Harness by duplicating one of the examples provided (see 
Triangle MicroWorks on the Start menu) and registering the server in tmwstart.tcl (search for 
SDNPSim). If you would like a simulator of your device included in the Test Harness, send a copy of 
the script file to support@TriangleMicroWorks.com . 
 

 
Figure 8. Example Slave Simulator 

 
Setting the Load Current to over 400 amps will cause a trip condition. To close the breaker again, lower 
the current below 400 amps and click on the CLOSE button in the image of the relay. The cursor will 
change to a hand symbol when placed over any button in the image that is active. 
 

Using Workspaces 
To save the current Test Harness configuration, use the File->Save Workspace menu option or the  
button on the tool bar of the main window. The workspace includes the communications parameters, 
Command Window, and Data Window settings. 



 
Once a Workspace has been saved, it can be loaded via the File->Open Workspace menu option or the 

 button on the main window. It can also be selected from the Select Test Harness Workspace window 
that opens on startup. 
 
To configure the Test Harness to automatically load a favorite workspace each time the Test Harness is 
started, edit the tmwstart.tcl file located in the Test Harness executable directory. To edit this file, select 
Edit Startup Script from the Windows Start->Programs->Triangle MicroWorks->Protocol Test 
Harness menu. Then scroll to the bottom of the file and follow the instructions for inserting the name of 
the workspace. 

Other Test Harness Features 

Conformance Test Scripts 
Triangle MicroWorks also offers Conformance Test scripts. These scripts perform the conformance test 
procedures published by the technical committees of each protocol. The Conformance Test Scripts are 
very useful as a periodic regression test during continued product development or in preparation for 
third party testing. 
 
The Conformance Test Scripts are licensed separately. However, a subset is always enabled for 
evaluation. To run the Conformance Test Scripts, click on the  button on the Test Harness main 
window tool bar. An example of the Conformance Test scripts is shown in Figure 9. 
 

 
Figure 9. Conformance Test Scripts 

 
For information on licensing the Conformance Test Scripts, contact Triangle MicroWorks at 
sales@TriangleMicroWorks.com. 
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Validating Points and Controlling External Instrumentation 
The Communication Protocol Test Harness can control external instrumentation such as the OMICRON 
CMC156 or CMC256 voltage and current generators to establish test conditions and confirm external 
results. 
 

 
Using the command window shown to the left, a sequence of 
commands can be configured to run automatically. 
 
Commands may establish a condition in the Device Under Test 
through a communication protocol command, a dialog box 
instructing the user to change the test conditions, or a command 
to control external equipment (notice the Omicron icon).  
 
After this, data is read from the Device Under Test through the 
communication protocol.  The Validate points command can then be 
configured to ensure a selected group of points have reached expected 
values. 
 
The command window to the left sets up 5 different test 
conditions (2 via DNP3 trip/close commands, 2 via the 
CMC156, and 1 via a user prompt) and validates selected points 
in the data base after each test condition. 
 
Double click the OMICRON command description to configure 
the OMICRON. 
 
To run the commands, use the Run->Run All Commands 
command. The test conditions must initially be set up by right 
clicking on the point in the Point Validation Configuration 

window and setting the value. The Run->Run All Commands & Update Expected Values command can 
be used to set the subsequent test conditions for all Validate Points Commands.  
 
Test Harness can automatically run all commands in this window whenever the workspace is loaded. To 
configure this option, select  Options->Run All Commands When Load Workspace. 

Monitoring Connections 
The communication Protocol Test Harness can also be used to monitor existing connections. This 
feature is currently supported for DNP3, IEC 60870-5-101 and IEC 60870-5-103 serial connections; 
support for TCP/IP and other protocols will be added soon. 
 
To open a Monitor connection, click on the Open Connection button ( ). An Open Connection Dialog 
box will appear, as shown in Figure 10. Then configure the channel in the Open DNP3 Monitor Channel 
dialog box, as shown in Figure 11. 
 



 
Figure 10. Opening a Monitor Connection 

 

 
Figure 11. Open Monitor Channel 

Note that in order to monitor both directions of a full-duplex connection (such as RS-232), two monitor 
channels must be opened (one for each direction). Special cabling is also required. The required cable is 
shown in Figure 12. 
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Figure 12. Full Duplex Monitor Cable Wiring Diagram 
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